HowTo, Segurança

Instalando o Ossec-WUI ( Web Interface )

O Ossec-WUI é uma ferramenta web que centraliza as informações sobre o servidor do Ossec HIDS e de seus agentes. Ele possui informações em tempo real do alertas, estatísticas e etc.

A instalação do Ossec-WUI ocorrerá na mesma máquina onde foi instalado o Ossec Server

Baixe o Ossec-WUI

wget http://www.ossec.net/files/ui/ossec-wui-0.3.tar.gz

Descompacte o arquivo baixado no diretório /var/www

tar -xvf ossec-wui-0.3.tar.gz -C /var/www/

Acesse o diretório /var/www e renomei o diretório ossec-wui-0.3

cd /var/www/

mv ossec-wui-0.3 ossec-wui

Acesse o diretório ossec-wui e execute o arquivo setup.sh para inciar a instalação

cd ossec-wui

debian:/var/www/ossec-wui# ./setup.sh

Setting up ossec ui…

Username: admin [ Informe o nome do usuário ]
New password:  [ Digite uma senha ]
Re-type new password:  [ Repita a senha digitada anteriormente ]
Adding password for user admin

Setup completed successfuly.

Adicione o usuário do Apache ( www-data ) ao grupo ossec

adduser www-data ossec

Dentro do diretório /var/www/ossec-wui altere as permissões e o grupo do diretório tmp

chmod 770 tmp/

chgrp www-data tmp/

Edite o arquivo /etc/php5/apache2/php.ini

vim /etc/php5/apache2/php.ini

e altere as seguintes linhas informando os valores abaixo:

max_execution_time = 180
max_input_time = 180
memory_limit = 30M

Reinicie o Apache

apache2ctl restart

Usando um navegador acesse o servidor http://[IP_SERVIDOR]/ossec-wui

ossec-wui

Feito. Agora podemos gerenciar o servidor do Ossec HIDS e seus agentes através do Ossec-WUI

Fonte:

Ossec Web Intarface Install

creysson.jpg

3 Comments

  1. cara estou com um erro no ossec-wui na aba integrity checking quando clico em dump database aparecem os seguintes erros será q vc tem alguma ideia do q possa ser?

    Warning: arsort() expects parameter 1 to be array, null given in /var/www/ossec-wui/lib/os_lib_syscheck.php on line 97

    Warning: Invalid argument supplied for foreach() in /var/www/ossec-wui/lib/os_lib_syscheck.php on line 98

    1. Olá Rafael,

      Você seguiu o procedimento de instalação corretamente?

      Uso o WUI aqui e não aparece nenhum erro.

      Recomendo que você analise os passos realizados para ver se não faltou nada.

      Abs,

      Alexos

Comments are closed.